Navigation
Supportsider
Senest Online
helmuth 3 Dage
makronen 2 Uger
gittedl 2 Uger
flj 3 Uger
ejvindh 3 Uger
afoster 3 Uger
HenningS 5 Uger
Niller 5 Uger
wholle11 Uger
Henrik Bendtsen13 Uger
Besøgende
Gæster online: 4

Brugere online: 0

Antal brugere: 182
Nyeste bruger: Michael Mogensen
Se indlæg
 Udskriv debat
fejlmeddelelse i forb. med opdatering
AlexF
Jeg er ved at opdatere www.testpladsen.dk fra 7.01.02 til seneste udgave.
Jeg er kommet til 7.02.02 og får denne fejlmeddelelse:

templates/panels.php(74) : eval()'d code
Use of undefined constant ini_get - assumed 'ini_get' Linje: 11

Formoder det er en fil i themes/templates men kan ikke finde ud af hvor eller hvad fejlen er.

Er der nogen som har et bud?
 
http://www.testpladsen.dk
flj
Har du nogen panels/elementer, der ikke er standard? I så fald prøv at slå dme fra og se om ikke det hjælper.
 
AlexF
Sorry at jeg ikke har svaret før.
Jeg fandt ud af at en infusion hsgallery_panel er problemet.

I min version er der brugt "Safemode on" som ikke eksisterer mere.

Nogen forslag til hvordan man så ændrer dette?
 
http://www.testpladsen.dk
flj
Det er nok en mindre rettelse. Kan du poste koden til hsgallery_panel her?
 
AlexF
Koden til selve elementet er her:

$title = "Billeder";
$query = "SELECT * FROM ".DB_PHOTOS." WHERE album_id='8' ORDER BY photo_datestamp DESC ";

$result = dbquery($query);

openside($title);
echo(" >");

while($data = dbarray($result))
{
$file = PHOTOS.(!@ini_get("safe_mode")? "album_".$data['album_id']."/" : "").$data['photo_thumb1'];
if (!file_exists($file)) $file =IMAGES."imagenotfound.jpg";

echo("");
}

echo("
'".$data['photo_title']."'  
");
closeside();

Link til download af selve fusionen er den her:

http://www.php-fusion.co.uk/infusions/addondb/view.php?addon_id=6
 
http://www.testpladsen.dk
flj
Prøv at erstatte

$file = PHOTOS.(!@ini_get("safe_mode")? "album_".$data['album_id']."/" : "").$data['photo_thumb1'];

med

$file = PHOTOS."album_".$data['album_id']."/".$data['photo_thumb1'];

i ovenstående kode
Hvis det ikke virker, er det nok fordi du har kørt med SAFE MODE ON. Så skal du nok bruge

$file = PHOTOS.$data['photo_thumb1'];

Det kan dog godt være, at det giver problemer med nye billeder.
 
AlexF
@flj,
Stor tak for hjælpen.
Den sidste løste problemet.
Så dette spørgsmål er løst
 
http://www.testpladsen.dk
Spring til debat: