Navigation
Supportsider
Senest Online
helmuth 3 Dage
makronen 2 Uger
gittedl 2 Uger
flj 3 Uger
ejvindh 3 Uger
afoster 3 Uger
HenningS 5 Uger
Niller 5 Uger
wholle11 Uger
Henrik Bendtsen13 Uger
Besøgende
Gæster online: 7

Brugere online: 0

Antal brugere: 182
Nyeste bruger: Michael Mogensen
Se indlæg
 Udskriv debat
æøå vises ikke
janmol
Er lidt klemt for tid lige nu, men noterer dit forslag. Selvom jeg egentlig synes, at one.com burde betale kontant for, at vi på den måde skal hjælpe deres brugere Pfft
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
flj
Du kan jo spørge dem Wink

Og sagde ikke, at DU skulle gøre det. Det meste info er vel at finde i debatten? Handler det ikke om at gøre ens site 110% UTF-8 agtig?
 
johnnysks

Citer

janmol skrev:

Der kom et forslag i en af de poster, som desværre blev slettet i forbindelse med serverflytningen. Det har jeg brugt på en side ved One.com, og det virkede.

I maincore som ny linje 2:

header('Content-Type: text/html; charset=iso-8859-1');


I .htaccess som en ny linje 2:


AddDefaultCharset ISO-8859-1


Det virkede i hvert fald på den side, som jeg rettede til.


Jeg kan ikke helt finde ud af, hvorhen det her er :D - Kan du beskrive det lidt mere?
Med Venlig Hilsen
Johnny Sørensen

www.DK-EVENT.dk
 
http://www.dk-event.dk
HenningS
www.eurodrivers.dk/images/articles/maincore.png
I maincore som foto

I .htaccess ligger i roden

Lykke til
HenningS tilknyttede følgende billede:fil:
Du har ikke lov til at se downloads i denne debat.

Henning
 
johnnysks

Citer

HenningS skrev:

www.eurodrivers.dk/images/articles/maincore.png
I maincore som foto

I .htaccess ligger i roden

Lykke til

Mange tak for billedet, det gav mig lige en bedre mulighed for og kunne forstå det Grin - Men jeg har bare ikke sådan vist med "linje 2" har ikke nogen linjer i den måde som jeg ser dem på!

men ser ud til at virke nu eller rettet nogen af de debatter som jeg har haft oprettet står med nogen andre tegn nu
Med Venlig Hilsen
Johnny Sørensen

www.DK-EVENT.dk
 
http://www.dk-event.dk
Mikkel45
Hejsa
Ja jeg er nok dummere end vådt bølgepap til dette.
Sådant som jeg forstår det skal der som linie 2 skal indsættes "header('Content-Type: text/html; charset=iso-8859-1');"
Et lille udpluk af min ser sådant ud, .... hvor er linie 2 ?

| Filename: maincore.php
| Author: Nick Jones (Digitanium)
+--------------------------------------------------------+
| This program is released as free software under the
| Affero GPL license. You can redistribute it and/or
| modify it under the terms of this license which you
| can read by viewing the included agpl.txt or online
| at www.gnu.org/licenses/agpl.html. Removal of this
| copyright header is strictly prohibited without
| written permission from the original author(s).
+--------------------------------------------------------*/
if (preg_match("/maincore.php/i", $_SERVER['PHP_SELF'])) { die(); }

error_reporting(E_ALL);

// Calculate script start/end time
function get_microtime() {
list($usec, $sec) = explode(" ", microtime());
return ((float)$usec + (float)$sec);
}

// Define script start time
define("START_TIME", get_microtime());

// Prevent any possible XSS attacks via $_GET.
if (stripget($_GET)) {
die("Prevented a XSS attack through a GET variable!");


PS. og hvor ligger htaccess ? ... jeg kan ikke se noget der hedder sådant i roden

Mvh
Peter
www.daek38.dk
Redigeret af Mikkel45 d. 06-04-2015 13:30
 
janmol
Du kan gøre det sådan her:


| Filename: maincore.php
| Author: Nick Jones (Digitanium)
+--------------------------------------------------------+
| This program is released as free software under the
| Affero GPL license. You can redistribute it and/or
| modify it under the terms of this license which you
| can read by viewing the included agpl.txt or online
| at www.gnu.org/licenses/agpl.html. Removal of this
| copyright header is strictly prohibited without
| written permission from the original author(s).
+--------------------------------------------------------*/
if (preg_match("/maincore.php/i", $_SERVER['PHP_SELF'])) { die(); }
header('Content-Type: text/html; charset=iso-8859-1');


.htaccess er ikke en standardfil. Men du kan jo bruge den (læg den på roden), som jeg har vedhæftet her.
janmol tilknyttede følgende billede:fil:
Du har ikke lov til at se downloads i denne debat.

Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
Mikkel45
10000 tak, det hjalp med det samme
 
janmol
Fint!!
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
mick
For mit vedkommende, har det været nødvendigt, at ændre php-versionen til 5.4 fra den nuværende 5.6. Jeg blev fortalt hos one.com, at 5.6 ikke var ret begejstret for andet end UTF-8.

Til gengæld er der ikke ret mange problemer med kombinationen af ovenstående og de fif Jan og andre er kommet med - Smile

(Red: de skide smiley'er altså)
Redigeret af mick d. 22-06-2015 19:32
Responsiv - naturligvis
 
http://www.kjellerup.biz
Exxtreme
Hejsa

Jeg havde samme problem på min Synology server som står hos mig privat... Det hjalp at rette maincore.php til samt at placere .htaccess filen i roden...

Jeg har dog stadig problemer flere steder på siden:

De steder i menuer eller administrationen hvor der indgår et æøÃ… i linket, der vises æøÃ… og de bogstaver der måtte komme efter ikke.

Et par eksempler er i navigationsmenuen hvor der burde stå "Søg" står der bare "S" hos mig, samt i administrationen under fanen opsætning, her burde der stå "Brugerhåndtering" under første ikon (gætter jeg på) men der står bare "Brugerh" hos mig...

Nogle gode bud på hvordan jeg får dette løst?
 
janmol
Du kunne prøve at skifte sprog på siden - først til engelsk og så tilbage til dansk igen. Måske kan det hjælpe ...
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
Exxtreme

Citer

janmol skrev:

Du kunne prøve at skifte sprog på siden - først til engelsk og så tilbage til dansk igen. Måske kan det hjælpe ...
Det hjalp desværre ikke...
 
janmol
Hvis det kun er i navigationslinkene, så kunne du jo rette dem manuelt direkte i databasen ...
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
Exxtreme
Det er det ikke... Hvis jeg f.eks. går ind i hovedindstillingerne hvor "introduktion til siden" står, og retter i teksten, så gør den det samme her...

Standard teksten:
Velkommen til din side


Hvis jeg indsætter et æ et vilkårligt sted, så slettes den eftergølgende tekst, både på siden hvor teksten vises, men også i administrationen hvor jeg retter teksten...

Hvis jeg f.eks. retter teksten til:
Velkommen æ til din side
og trykker "gem ændringer" så kan jeg med det samme se at feltet rettes til
Velkommen
og det forsår jeg bare ikke et klap af?
 
johslind
Jeg bør nok sige undskyld, at jeg blander mig; for jeg bruger stort set ikke PHP_Fusion mere. Men på den anden side har jeg det tilfælles med en del af jer, at jeg bruger One.com. Og måske har jeg en løsning på en del af problemerne, der er affødt af, at serveren er gået over til UTF-8.

I mit eget tilfælde fik jeg hurtigt indført en .htaccess i roden. Det løste de fleste problemer. Men i eet tilfælde hjalp den løsning ikke. Jeg har på min hjemmeside geltzer.dk en masse filer med gamle tingbøger. Nogle gange har jeg husket at erstatte æ, ø og å med de tilsvarende entiteter, andre gange ikke. Det betyder, at jeg i en søgefunktion er nødt til at søge på begge muligheder. Efter serverens overgang til UTF-8 kom der så en fejlmelding om en tom variabel i det tilfælde, ordet indeholdt et af de danske bogstaver.

Nu har jeg så fundet ud af, at funktionen htmlentities() fuldstændigt vil ignorere et ord, hvis det indeholder et ugyldigt tegn, samt at man kan tilføje forskellige "flag" til funktionen. Der et flag, der simpelthen dropper det pågældende tegn, og der er også et, der erstatter det pågældende tegn med en kode fra UTF-8. I begge tilfælde opnår man i det mindste, at variablen med entiteter i det mindste ikke kommer til at stå tom, hvilket betyder, at man slipper for fejlmeldingen og trods alt får vist de poster, der indeholder ordet uden entiteter.

Men så er der også et andet flag, der prøver at styre brugen af tegnsæt. Nu ser min kommando om htlmentities sådan ud:


$ordet2=htmlentities($ordet,ENT_SUBSTITUTE,$encoding = ini_get("default_charset"));

Det ser ud til at have løst alle mine problemer.

Kig selv efter på php.net.
Redigeret af johslind d. 22-11-2015 15:47
Med venlig hilsen,
Johs. Lind
yndlingshost: Gigahost
 
http://geltzer.dk
MTeis
Nogen der ved om det er det samme hos Web10.dk?

Min side www.moen-net.dk har nemlig samme problem.

Siden kører PHP 5.3.3
Redigeret af MTeis d. 08-06-2016 14:47
venligste hilsner
MTeis
 
www.e28.dk
HenningS
Det ligner samme opgave som vi andre har haft, kender ikke til din webudbyder, men er sikker på at der lige er to - tre steder der skal rettes til.
Henning
 
flj
Kan være svært at hjælpe uden flere detaljer, men prøv at lægge dette i .htaccess:

AddDefaultCharset ISO-8859-1

 
MTeis
Hej flj,

Det hjalp - 1000 tak for hjælpen.
Havde slet ingen .htaccess fil i roden, men kopierede en fra en anden side jeg kører og indsatte din tilføjelse o0g det virkede ;o)

Sorry for sent svar, men har først lige nu set dit svar!
venligste hilsner
MTeis
 
www.e28.dk
flj
Bare godt det virkede
 
Spring til debat: