Navigation
Supportsider
Senest Online
helmuth 3 Dage
makronen 2 Uger
gittedl 2 Uger
flj 3 Uger
ejvindh 3 Uger
afoster 3 Uger
HenningS 5 Uger
Niller 5 Uger
wholle11 Uger
Henrik Bendtsen13 Uger
Besøgende
Gæster online: 3

Brugere online: 0

Antal brugere: 182
Nyeste bruger: Michael Mogensen
Se indlæg
 Udskriv debat
æøå vises ikke
jensjac
Hej alle gode folk
One.com har opgradret deres php. Efter at dette er sket viser siden www.fola.dk æøå som ?.
Er der nogen der kan hjælpe mig med forslag til hvordan jeg retter fejlen?
Venlig hilsen
Jens
 
janmol
Der kom et forslag i en af de poster, som desværre blev slettet i forbindelse med serverflytningen. Det har jeg brugt på en side ved One.com, og det virkede.

I maincore som ny linje 2:

header('Content-Type: text/html; charset=iso-8859-1');


I .htaccess som en ny linje 2:


AddDefaultCharset ISO-8859-1


Det virkede i hvert fald på den side, som jeg rettede til.
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
HenningS
Til supplement - i sprogfiler under global php hos mig linje 11
sættes dette ind $locale['charset'] = "utf8";

Obs det virkede på version 7.02.07

Lykke til, og ja, det var en af de modne der smutter ved opdatering
Redigeret af HenningS d. 03-03-2015 23:13
 
jensjac
Jeg har frosøgt mig med Jans løsningsforslag.
Det virkede.
Tak for hjælpen.
Venlig hilsen
Jens
 
janmol
Mægtigt
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
Harped
Smukt at der allerede er svar (skiftede PhP på one.com version den 1.)
Den første linie i maincore.php ændrede ? til mærkelige karakterer
Har dog et problem med at finde .htaccess, og har derfor ikke fået løst problemet:
Hvor ligger den?
 
janmol
Hvis den ikke findes, så kan du oprette den selv. Ellers kan du finde en på dette link: http://php-fusion.dk/files/access.zip
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
Harped
Takker, men måske er jeg 50% dummere end en skål havregrød Wink
Jeg har stadig ikke fattet i hvilken php-fil indholdet - eller hvor ".htaccess" skal kopieres/lægges ind.
 
janmol
Du lægger .htaccess på roden på din server. Og så skal der rettes i maincore.php som beskrevet længere oppe i denne tråd. Og eventuelt også i global.php under locale/Danish.
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
Harped
Jeg bukker og takker - det løste problemet
Smukt med de hurtige svar
 
janmol
Dem håber vi at kunne komme med nogle flere af fremover Wink
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
Jens Solvang
Svar 3 viser mærkelig æ og å. Kan man også komme til at sende et fejl tegnsæt, så vores hovedside ikke viser ret.

Hvordan mon det sker? Kan man selv gøre for det?
 
janmol
Også det skulle så vidt jeg kan se være i orden nu.
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
Jens Solvang
Det var dejligt - det kan jeg se.

Og - heldigvis har jeg fået en mail om at der var kommet svar til mig. Hermed tilbagemelding. Dejligt - tak for arbejdet.
 
minverden
Jeg kører med v7.02.03 . Når jeg prøver at lave disse ændringer, som Jan bl.a. nævner, så bliver æ, ø, og å til nogle mærkelige bogstaver? Lige nu har jeg kun nogle steder et "spørgsmåls-tegn symbol", hvis jeg ikke laver ændringerne. Skal mon først lave en opdatering af systemet før det her virker eller er der en anden løsning?
 
Jens Solvang
Jeg har ikke oversigt over hvornår der sker ændringer i løbet af 7-serien.
Jeg vil forslå at du stiller spørgsmålet igen i "Generelt om php-fusion v7". Så bliver det nok lettere at finde senere for andre brugere.
 
minverden
@jens, hvorfor....jeg har skrevet det under version 7 og jeg bruger jo også version 7!
 
Jens Solvang
undskyld @minverden - jeg læste fejl. Du er jo i den rigtige tråd - undskyld.
 
minverden
@jens, bare i orden Wink
 
janmol
De problemer, som vi har skrevet om her, opstår hos brugere, hvis side ligger på One.com (i forbindelse med at One.com skifter PHP-version til 5.3). Hvis du har en side på One.com, men ikke har oplevet problemet endnu, så skyldes det nok, at de endnu ikke har opgraderet den server, som din side ligger på. Og så skal du intet gøre.
Take it easy but take it.
.........................................................
Jan Mølgaard, it-konsulent og oversætter
http://wordit.dk
 
http://wordit.dk
HenningS

Citer

janmol skrev:

Der kom et forslag i en af de poster, som desværre blev slettet i forbindelse med serverflytningen. Det har jeg brugt på en side ved One.com, og det virkede.

I maincore som ny linje 2:

header('Content-Type: text/html; charset=iso-8859-1');


I .htaccess som en ny linje 2:


AddDefaultCharset ISO-8859-1


Det virkede i hvert fald på den side, som jeg rettede til.



Jeg kan supplerer med at man i version 06.01.14 blot skal rette i maincore som beskrevet herover..

Godt nok en ældre version som ej er opdateret men køre fint.
Henning
 
Spring til debat: